Super Admin Experience outage on "My Projects"
Incident Report for LinguistLink
Monitoring
this seems to be functional. still researching the root cause.
Posted Oct 25, 2024 - 16:03 UTC
Investigating
This is only affecting super admins at this time.
Posted Oct 24, 2024 - 19:22 UTC
This incident affects: LinguistLink Portal.